RStudio Connect 1.7.4.2 - Important Security Patch

June 12, 2019

This RStudio Connect patch release addresses an urgent security update and an important bug fix.

  • Security Update: Password Authentication
    A vulnerability has been identified for customers using RStudio Connect’s built-in password authentication. Due to the risks involved, password authentication will now require the configuration setting Server.Address for operations that will send emails. If this setting is not configured an error will occur for these operations. More detailed information about the vulnerability will be released in a future post. We have received no reports of impacted customers, but we recommend customers using password authentication upgrade immediately.

  • Bug Fix: SLES Installer
    Prior versions of RStudio Connect used a shared RPM installer for SLES and RedHat. This installer was found to be incompatible for customers upgrading to SUSE Linux Enterprise Server 12 SP4 and SUSE Linux Enterprise Server 15. This version introduces a separate installer for SUSE systems. See the download page for details.

Upgrade Planning
There are no special considerations when upgrading from RStudio Connect v1.7.4 to this patch release. Upgrades should take less than five minutes. If you are upgrading from an older release, please consult the intermediate release notes.

More information on the new features added in RStudio Connect 1.7.4 is available in a prior post.

Previous Article
RStudio Connect 1.7.4.2 - Important Security Patch
RStudio Connect 1.7.4.2 - Important Security Patch

This RStudio Connect patch release addresses an urgent security update and an important bug fix. Security ...

Next Article
Oauth2 authentication
Oauth2 authentication

@wsgomaa wrote: Dears, Can I use Oauth2 authentication in RStudio Connect to aut...