RStudio Connect - Test Email Sends, but User Invites Do Not

April 23, 2019 @laynesadler Layne Sadler

@laynesadler wrote:

Hey there. I was able to stand RStudio Connect up on Ubuntu 18.04 on EC2, and successfully Published the histogram app (the default... File>New>ShinyApp) to the server. Huzzah!


EMAIL ISSUE:
I tried to invite some coworkers to the Connect server by creating users, but it said I need to setup email. I get it... there is no ActionMailer equivalent for this framework yet.

So from the Connect web UI setting page, I was able to setup SMTP for MailGun and send a test email successfully (I did this after successfully sending a test email by configuring Sendmail from command line).

However, neither method allowed me to successfully send User Invites. I just get the message: “Error: Unable to send email. Please contact your RStudio Connect administrator.”


UPDATE: This is a fresh install of R and Connect as of this afternoon. I am a new user (aka the feature never "used to work"). I tried restarting the EC2 machine, restarting the connect service, logging out/in of the web portal, and the good ol' fashion just wait an hour or two for something different to happen.

[RStudio Connect] Test Email
RStudio Connect <layne.sadler@gmail.com>	
Tue, Apr 23, 2019 at 4:51 PM
To: layne.sadler@gmail.com

This is a test of RStudio Connect's email sending configuration.

Posts: 5

Participants: 3

Read full topic

Previous Article
ETL with R Markdown on RStudio Connect - Output files
ETL with R Markdown on RStudio Connect - Output files

@kellobri wrote: This blog is a how-to guide for leveraging R Markdown output fi...

Next Article
Connecting to rstudio server outside of local network
Connecting to rstudio server outside of local network

@clad wrote: I created a server in a virtual Box ubuntu machine and it is runnin...